Services Vulnerabilities Exploits Publications News Blog About DSecRG


[DSECRG-08-030] Claroline 1.8.9 - Multiple Security Vulnerabilities (XSS,XSRF)

Claroline system has multiple security vulnerabilities:

1. Multiple Linked XSS
2. Phishing Through URL Redirection
3. Change User Password XSRF Vulnerability


Application: Claroline eLearning and eWorking platform
Versions Affected: 1.8.9
Vendor URL: http://www.claroline.net/
Bug: Multiple XSS, Phishing Through URL Redirection, Change User Password XSRF Vulnerability
Exploits: YES
Reported: 04.07.2008
Vendor Response: 07.07.2008
Solution: YES
Date of Public Advisory: 18.07.2008
CVE-number: 2008-3260, 2008-3261, 2008-3262
Author: Digital Security Research Group [DSecRG] (research [at] dsec [dot] ru)


Details
*******

1. Multiple linked XSS vulnerabilities found. Attacker can inject XSS in URL string

1.1 Linked XSS vulnerabilities found in scripts:

claroline/announcements/announcements.php
claroline/calendar/agenda.php
claroline/course/index.php
claroline/course_description/index.php
claroline/document/document.php
claroline/exercise/exercise.php
claroline/group/group_space.php
claroline/phpbb/newtopic.php
claroline/phpbb/reply.php
claroline/phpbb/viewtopic.php
claroline/wiki/wiki.php
claroline/work/work.php

Attacker can inject XSS in URL string.

Example:

http://[server]/[installdir]/claroline/course/index.php?"><script>alert('DSecRG XSS')</script>
http://[server]/[installdir]/claroline/phpbb/newtopic.php?"><script>alert('DSecRG XSS')</script>


1.2 Linked XSS vulnerability found in claroline/document/rqmkhtml.php

GET parameter "cwd"

Example:

http://[server]/[installdir]/claroline/document/rqmkhtml.php?cmd=rqMkHtml&cwd="><script>alert('DSecRG XSS')</script>

---------------------------------------------------------------------


2. Phishing Through URL Redirection

Vulnerability found in script /claroline/redirector.php

GET parameter "url"

Example:

http://[server]/[installdir]/claroline/redirector.php?url=http://evilsite.com

---------------------------------------------------------------------


3. Change User Password XSRF Vulnerability

Previous password not required to set a new password.

Using XSS vulnerabilities, attacker can change user password.


Solution
********

Vendor fix this flaw on 16.07.2008. New version 1.8.10 can be downloaded here:

http://downloads.sourceforge.net/claroline/claroline1810.tar.gz
http://downloads.sourceforge.net/claroline/claroline1810.zip


About
*****

Digital Security is leading IT security company in Russia, providing information security consulting, audit and penetration testing services, risk analysis and ISMS-related services and certification for ISO/IEC 27001:2005 and PCI DSS standards. Digital Security Research Group focuses on web application and database security problems with vulnerability reports, advisories and whitepapers posted regularly on our website.


Contact: research [at] dsec [dot] ru
http://www.dsecrg.ru
http://www.dsec.ru

Vulnerabilities RSS RSS
21.03.2012
[DSECRG-12-019] vCenter Orchestrator - password disclosure

22.02.2012
[DSECRG-12-018] Oracle Application Server - multiple security vulnerabilities

17.02.2012
[DSECRG-12-017] ASUS Net4Switch ipswcom.dll ActiveX - buffer overflow vulnerability

17.02.2012
[DSECRG-12-016] SAP MessagingSystem - information disclosure

17.02.2012
[DSECRG-12-014] SAP Internet Sales - XSS

17.02.2012
[DSECRG-12-015] SAP Adapter Monitor - information disclosure

Vulnerabilities list


© 2002—2014, ERPScan
For quoting or using materials from this site
link is obligatory

+44 (20) 81334493    e-mail: research@dsecrg.com
Rss: Vulnerabilities, Exploits, News, Publications, Summary
Search